Offroad Trailblazers and Envoys

Stuck in park / Shift interlock solenoid

Something not working right?

by Clank » Tue Aug 13, 2019 9:39 pm

Hey guys, recently my truck got stuck in park and after researching it seems that it's most likely my Shift interlock solenoid was bad. It still works but periodically gets stuck in park and I have to push the override button in to shift. I ordered a new one (ACDelco) and just put it in. It now shifts fine but for some reason the key will not turn all the way off in the ignition. It gets sorta stuck halfway between accessory mode and off and the dash/radio lights will sort of flicker. I've tried turning the wheel and putting my foot on the brake with no luck. If I plug the old solenoid in it works perfectly fine. At first I thought my ignition switch was bad but the fact that it fails only with the new solenoid leads me to believe I got a bad part. The part numbers are the exact same I even took the covers off the solenoids and the internals both look good. Just looking for opinions before I ship the part back for a refund
Posts: 3
Joined: Sun May 14, 2017 9:39 pm
Name: Mason
Vehicle Year: 2008
Vehicle: Chevrolet TrailBlazer
DriveTrain: 4WD

by Smartin11 » Wed Aug 14, 2019 3:07 am

I once went through 3 alternators on a isuzu rodeo before I got one that actually worked. And that was from advance auto parts. New parts definitely have a potential fail rate. I'd try a new one!
Posts: 17
Joined: Mon May 30, 2016 4:32 pm
Location: Orlando, FL
Name: Sean
Vehicle Year: 2003
Vehicle: Chevrolet TrailBlazer
DriveTrain: 4WD

Return to Troubleshooting