Offroad Trailblazers and Envoys

Shifter stuck in reverse

If its been completed, and doesn't fit into another category, stick it here.
Forum rules
Threads must fully document the modification with pictures and verbiage in the first post.
Threads that do not meet this criteria may be moved or deleted.

by navigator » Sun Aug 12, 2012 12:34 am

ok, I got in the TB the other night to move it and the shifter was stuck in reverse.
From reading several threads here, GMTN and the OS I decided to check the shifter cable.
As you can see, it had come loose....
Broken.jpg


I didn't really mess with it a whole lot, once I saw it was loose, I ordered the part from ATFSpeed.
The process is really straightforward and the instructions are pretty accurate.
I feel like the kit is overpriced and shipping is high ($30 total) but the parts seem solid and it is much cheaper than a cable.

http://www.atfspeed.com/store/index.php ... cts_id=568

I ordered it on Thursday and it arrived via USPS on Sat.

I used a 15mm to remove the nut and an 11mm to hold the shifter shaft to make sure it didn't move.
I took a picture of the arm and the wrenches so I wouldn't forget which ones I needed.

ArmRemoved.jpg


Once I removed the arm, I needed to grind the head off the back of the old stud so I could punch it out.

GrindBack.jpg


Once I ground the head off, I punched the stud out of the arm.

StudRemoved.jpg


Once the stud is removed, re-attach the arm.
The instructions say to flip the arm and have the "ground" side to face the tranny pan. I tried doing that but my arm only goes on one way else it won't re-connect back to the cable. This was the only incorrect part of the instructions at least for my 2006 model.

The new stud goes through the cable itself, not back in the arm. It is a really tight fit. I thought I would have to file away a little plastic but a little lube worked just fine. I was able to use my channel-lock pliers to kind of press it in place.
NewStudinstalled.jpg


Once the stud was installed you just insert the tip back in the arm and put on the E-clip and you are done.
AllDone.jpg


My only hiccups were the fact that only one e-clip came in the pack and while I was grinding the back of the old stud off, my envelope blew out of the TB and into my yard and I lost it. I had to go to HF and get an $8 box of e-clips to replace it. The only other snag was I originally put the arm on backwards (per the instructions) and it wouldn't connect to the cable. Everything seems to fit well and the shifter works smooth again.

looking back I might have been able to make something work but I was afraid it might damage the cable end. There is also a replacement bushing that is like $10 shipped on ebay but I wasn't sure about it so I ordered the kit instead.

They sent two studs in the kit. The other one would have fit really tight but might work for someone else having this issue. I'll keep an eye on it and if it works ok, I might let the other one go to another member.
"Please consider a search before posting. Folks on this site PIONEERED functional offroad use of these trucks."
The answer to many common lift questions can be found
here
My Build Thread
User avatar
navigator
Moderator
 
Posts: 4649
Joined: Wed Mar 09, 2011 10:16 am
Location: NC, Winnabow
Name: Chris
Vehicle Year: 2006
Vehicle: Chevrolet TrailBlazer
DriveTrain: 4WD
Rank: Trail Ready

by blauthsp » Mon Jul 21, 2014 1:28 am

I know I am waaaay late on this but just incase it happens to someone else here is a much easier fix.

http://www.ebay.com/itm/Shifter-Shift-Cable-Trailblazer-Envoy-hummer-h2-rainier-ascender-HHR-Saab-/261438102224?pt=Motors_Car_Truck_Parts_Accessories&fits=Year%3A2005%7CModel%3ATrailblazer&hash=item3cdeecdad0&vxp=mtr

Just replace the missing or old/cracked piece at the end of the shift cable and save some time ;)
blauthsp
Newbie
 
Posts: 2
Joined: Mon Jul 21, 2014 1:19 am
Name: Shawn Blauth
Vehicle Year: 2005
Vehicle: Chevrolet TrailBlazer
DriveTrain: 4WD

by The Roadie » Mon Jul 21, 2014 11:28 am

Thanks for the find. That's a Dorman 14055 and it might also be available from local parts shops.
User avatar
The Roadie
Founder
 
Posts: 5009
Joined: Mon Sep 07, 2009 11:29 pm
Location: CA, Vista, San Diego County
Name: Bill Carton
Vehicle Year: 2004
Vehicle: GMC Envoy
DriveTrain: 4WD w/ G80
Rank: Expedition Guide


Return to Completed Modifications

cron